Eclips で Amazon AWS Toolkit を使う設定

Eclips で Amazon AWS Toolkit を使う設定です

AWS Toolkit for Eclipse を参考に設定します
https://aws.amazon.com/jp/eclipse/

Eclips を起動して、[ヘルプ] > [新しいソフトウェアをインストール] を開く

AWSEclips01
上記のように入力するとAmazon AWS Toolkit  を表示

AWSEclips02
全て選択して設定してみます

が、途中で以下のエラーで停止します

1 つ以上の必須項目が見つからないため、インストールを完了できません。
Software currently installed: Amazon SimpleDB Management 1.0.0.v201402141427 (com.amazonaws.eclipse.datatools.enablement.simpledb.feature.feature.group 1.0.0.v201402141427)
Missing requirement: Eclipse Data Tools Platform Amazon SimpleDB UI Plug-in 1.0.0.v201402141427 (com.amazonaws.eclipse.datatools.enablement.simpledb.ui 1.0.0.v201402141427) requires ‘bundle org.eclipse.datatools.sqltools.sqlscrapbook 1.0.0′ but it could not be found
Cannot satisfy dependency:
From: Amazon SimpleDB Management 1.0.0.v201402141427 (com.amazonaws.eclipse.datatools.enablement.simpledb.feature.feature.group 1.0.0.v201402141427)
To: com.amazonaws.eclipse.datatools.enablement.simpledb.ui [1.0.0.v201402141427]

AWS Toolkit for Eclipseのインストールエラー
http://devdev.hatenadiary.jp/

上記を参照すると、事前にDB関連のツールを入れておかなければならない様子
再度[ヘルプ] > [新しいソフトウェアをインストール] を開き

AWSEclips03
上記を選択し設定します

再会します
AWSEclips04

AWSEclips05
途中このメッセージが出てきますがOKで進みます

以上であっさり設定が完了して、Eclips を再起動します
再起動したらすぐ AWS の Access Key を聞いてきます

AWSEclips06
すでにアカウントは作っていますので、existing credentials のリンクをクリックしてキーを作成

AWSEclips07
ページがかわったとの事、新しい、、、のリンクをクリック

AWSEclips08
キーを作成します

AWSEclips10
作ったキーはファイルでダウンロードし、必ず非公開な場所で保管
Eclipsの画面に戻ってキーを登録

AWSEclips11
下にAWS Exproler が表示されていて、直感的に操作できます

AWSEclips12
EC2のインスタンスも覗けます!

その他、DynamoDBやS3なんかも直感的に操作しやすくて良い!

で、一番確認してみたかった Elastic Beanstalk のPHPを試すと

AWSEclips13
あらら、、、未対応ですね。(^^;;